Jump to content
Witchking

Could not open GL

Recommended Posts

my friend on LZ needs help

 

Quote:

 

Ok so today I formatted and installed Windows 7 and its by far the best windows yet if I do say so myself. So I dled ET and installed it successfully but when I run it I get the following error:

 

GLW_StartOpenGL() - could not load OpenGL subsystem

 

I have downloaded all the necessary drivers and Directx but it still won't let me boot up ET.

 

The message I get is the following:

 

 

ET 2.60b win-x86 May 8 2006

----- FS_Startup -----

Current search path:

C:\PROGRA~1\WOLFEN~1\etmain\pak0.pk3 (3725 files)

C:\PROGRA~1\WOLFEN~1\etmain\mp_bin.pk3 (4 files)

C:\PROGRA~1\WOLFEN~1/etmain

 

----------------------

3729 files in pk3 files

execing default.cfg

couldn't exec language.cfg

couldn't exec autoexec.cfg

Hunk_Clear: reset the hunk ok

...detecting CPU, found Intel Pentium III

Bypassing CD checks

----- Client Initialization -----

----- Initializing Renderer ----

-------------------------------

----- Client Initialization Complete -----

----- R_Init -----

Initializing OpenGL subsystem

...initializing QGL

...calling LoadLibrary( 'C:\Windows\system32\opengl32.dll' ): succeeded

...setting mode 4: 800 600 FS

...using desktop display depth of 32

...calling CDS: ok

...registered window class

...created [email protected],0 (800x600)

Initializing OpenGL driver

...getting DC: succeeded

...GLW_ChoosePFD( 32, 24, 0 )

...35 PFDs found

...GLW_ChoosePFD failed

...GLW_ChoosePFD( 32, 24, 0 )

...35 PFDs found

...GLW_ChoosePFD failed

...failed to find an appropriate PIXELFORMAT

...restoring display settings

...WARNING: could not set the given mode (4)

...setting mode 4: 800 600 FS

...using colorsbits of 16

...calling CDS: ok

...created [email protected],0 (800x600)

Initializing OpenGL driver

...getting DC: succeeded

...GLW_ChoosePFD( 16, 16, 0 )

...35 PFDs found

...GLW_ChoosePFD failed

...GLW_ChoosePFD( 16, 16, 0 )

...35 PFDs found

...GLW_ChoosePFD failed

...failed to find an appropriate PIXELFORMAT

...restoring display settings

...WARNING: could not set the given mode (3)

...shutting down QGL

...unloading OpenGL DLL

...assuming '3dfxvgl' is a standalone driver

...initializing QGL

...WARNING: missing Glide installation, assuming no 3Dfx available

...shutting down QGL

----- CL_Shutdown -----

RE_Shutdown( 1 )

-----------------------

GLW_StartOpenGL() - could not load OpenGL subsystem

Share this post


Link to post
Share on other sites

This means that ET's engine is unable to start OpenGL. Either his/her graphic drivers are corrupt or not installed. Get him/her to reinstall them. ;)

 

If that doesn't help, try googling. Fairly common problem :)

 

~

/*Pisi*/

Share this post


Link to post
Share on other sites

I'm the one who needs help. I have already updated my drivers but it still does not help. Its common sense to google something before posting and I did but could not find an answer.

 

My graphics card is the following:

 

Intel

Edited by 1Flash

Share this post


Link to post
Share on other sites

Ah, Intel integrated graphics... the enemy of gaming... :/

 

Sadly, Intel hasn't released Win7 drivers for this card. Installing drivers in xp/vista compability mode might help (I'm guessing you already did and it hasn't...) but it's definitely not guaranteed.

 

Sorry but I can only suggest either switching back to XP/Vista or getting a better pc (one without integrated graphics). :/

 

~

/*Pisi*/

Share this post


Link to post
Share on other sites

I was afraid of this, well I guess im going to have to wait until they do to play et or dual boot xp. Thank you for your help it was greatly appreciated :)

Share this post


Link to post
Share on other sites

No problem. :)

Personally, I'd dual boot Ubuntu for good ol' ET... but that's just me :P

 

~

/*Pisi*/

Share this post


Link to post
Share on other sites

Why not get a better video card? Hopefully your computer has a pci express card slot so buy a good video card and install it in that slot and disable the on board video card that you have been using. Then load up the drivers for your new video card and game away. If you finally buy or build a newer computer then remove the new card from your old computer and install it in your newer computer.

Share this post


Link to post
Share on other sites

Why not get a better video card? Hopefully your computer has a pci express card slot so buy a good video card and install it in that slot and disable the on board video card that you have been using. Then load up the drivers for your new video card and game away. If you finally buy or build a newer computer then remove the new card from your old computer and install it in your newer computer.

 

I know I was getting this problem when I made my Resolution to large for my pc. Try and do r_mode "4" in your autoexec.cfg, then open ET. Maybe it will work then.

Edited by Benway
nice guess, its a known issue though with video drivers that come with (any) Windoze, consider it a DirectX advert. fix: nvidia.com / ati.com
  • Upvote 2

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×

Important Information

By using this site, you agree to our Terms of Use.