Jump to content

Fear Pb config.


<<{BLS}>>Rave

Recommended Posts

Hello. I added a config to the pb folder and the command pb_dv_load for the pbsvuser.cfg. It seems that the md5 tool is working the logs show the checksums. The problem I am having is that the autoscreeners aren't showing up in the svss folder. I am using a pbsvgame.cfg, and have tried using a pbsv.cfg, but neither has worked. Also, was wondering how you can use commands in the server since it uses the SCMD. hl2sw maybe? Here is the config i'm using.

 

pb_sv_MaxDlRate 4 //[KB/sec requested per file (default=4)]

pb_sv_MaxConDls 5 //[concurrent downloads (default=1)]

pb_sv_KickLen 2 //[minutes (default=2)]

pb_sv_CvarFreq 6 //[# of range checks per minute]

pb_sv_CvarLogging 1 //[1=Reg. Log, 2=Var Log, 3=Both, 0=Neither]

pb_sv_CvarWalk 1 //[0=disabled, 1-4=Walk through obtained Cvar lists]

pb_sv_CvarUserPulse 99 //[How often (in min.) to auto-send CvarUser command]

pb_sv_CvarChangedPulse 99 //[How often (in min.) to auto-send CvarChanged command]

pb_sv_CQC 1 //[0=No, 1=Yes (default=1)]

pb_sv_LogSync 0 //[0=No, 1=Yes (default=0)]

pb_sv_LogCeiling 1000 //[High log filename serial #]

pb_sv_SsFloor 1 //[Low screenshot filename serial #]

pb_sv_SsCeiling 1000 //[High screenshot filename serial #]

pb_sv_SsCmd "" //[Filename of system command to run after screenshots]

pb_sv_SsWidth 320 //[Requested pixel width of remote screenshots]

pb_sv_SsHeight 240 //[Requested pixel height of remote screenshots]

pb_sv_SsXpct 50 //[Percentage across screen for remote screenshots]

pb_sv_SsYpct 50 //[Percentage down screen for remote screenshots]

pb_sv_SsSrate 1 //[sample Rate for remote screenshots]

pb_sv_SsDelay 0 //[Maximum delay client waits before capturing screenshot]

pb_sv_SsPath "" //[Path where remote screenshots are saved]

pb_sv_AutoSsFrom 60 //[Minimum # of seconds to wait before requesting next ss]

pb_sv_AutoSsTo 1200 //[Maximum # of seconds to wait before requesting next ss]

pb_sv_AutoSs 1 //[0=No, 1=Yes (default=0)]

pb_sv_Sleep 60 //[# of Milliseconds (default=60)]

pb_sv_PowerMin 10 //[power points]

pb_sv_PowerDef 1 //[power points]

pb_sv_PowerKickLen 5 //[minutes (default=5)]

pb_sv_scoreKick 0 //[minimum score (negative)]

pb_sv_changePeriod 999 //[seconds]

pb_sv_changeMax 1 //[max name changes allowed]

pb_sv_dupNameGrace 0 //[seconds]

pb_sv_autoUpdBan 0 //[0=No, 1=Yes (default=0)]

pb_sv_extChar 0 //[0=No, 1=Yes (default=0)]

pb_sv_guidRelax 0 //[1=UNKN, 2=WRONGIP, 4=DUP (add desired values)]

pb_sv_load pbsvuser.cfg

Link to post
Share on other sites

I need to add the line pb_sv_restart to the .cfg file? Cause as far as I know there isn't a way to issue commands in the server.

Link to post
Share on other sites

I need to add the line pb_sv_restart to the .cfg file? Cause as far as I know there isn't a way to issue commands in the server.

Really ? :huh:

 

Log in as administrator on server and then type in console :

 

pb_sv_restart

 

It should work. :huh: :huh:

Edited by Patachon
Link to post
Share on other sites

Ok, where is this console that I type anything in? I mean isn't everything for the SCMD done with the "say" command? And if you meant type it into the "say" command after logging into SCMD, what am I missing cause each time I try that it says "not a command" and gives me the list of available SCMD commands? I am new to Fear servers, but I admin SOF2 servers all the time and am very familiar with pb there and the console commands, just have never found a console to type in commands on our Fear servers.

 

 

I do have full access to the server as it is a server unit that I own, and have restarted the server many times. I will try the webtool, but I do have a feeling that it isn't going to be the issue as each time I do start the server, it does start logging and the entire cfg file does load according to the pblog. Anything else I maybe missing here?

Link to post
Share on other sites

Ok, got the webtool working, and did a few updates and restarts. Everytime I do issue one of those commands from the commands page, it says command issued, but then I only get black pages when I try and use the webtool more. Even if I try and go back to it from a new browser window, I have to actually restart the server in order to get back into the webtool. Any ideas why that is? Screeners still aren't being created though either.

Link to post
Share on other sites

It is a linux server unit that the Fear server is running on...will that make any difference? I notice the mention of Win32 at the top of that list. Let me know, and I'll give it a go. Thank you for your post.

Link to post
Share on other sites

It doesn't matter if it is a Linux or Windows server. The file is named the same of both OS

Link to post
Share on other sites

It doesn't matter if it is a Linux or Windows server. The file is named the same of both OS

Gotcha. Well, something must be amiss, cause I have tried the pbsv.cfg that was listed earlier here, but alas, no screeners. Where are they supposed to be created? I have a /fear/pb/svss folder but it remains empty. In SOF2 it creates a .sof folder alongside the SOF folder where it has a pb/svss folder where they are created. Is the FEAR/pb/svss folder the right directory for these screenshots to be created in, or is there something that isn't working right that maybe the reason they are not showing up?

 

Any other ideas? Kinda running out of them on this side.

 

Thanks for all your help so far.

Link to post
Share on other sites

You should set up web interface. Open pbsv.cfg and append at the end

pb_sv_httpAddr SRV_IP_HERE

pb_sv_httpPort ANY_FREE_NONBLOCKED_PORT_BIGGER_THAN_1024

pb_sv_httpKey TOP_SECRET

 

save and restart fear srv. Then open in your browser

SRV_IP_HERE:ANY_FREE_NONBLOCKED_PORT_BIGGER_THAN_1024

PB Web Interface is really usefull in fear.

Link to post
Share on other sites

Well, something must be amiss, cause I have tried the pbsv.cfg that was listed earlier here, but alas, no screeners. Where are they supposed to be created? I have a /fear/pb/svss folder but it remains empty. In SOF2 it creates a .sof folder alongside the SOF folder where it has a pb/svss folder where they are created. Is the FEAR/pb/svss folder the right directory for these screenshots to be created in, or is there something that isn't working right that maybe the reason they are not showing up?

The ss folder is game_folder_name/pb/svss

 

When you issue some commands you need to do a pb restart from the web tool (command will be saved to config but not in use otherwise)

 

Some ftp progies seem to have issue linux/fear/host, you should also try a manual file refresh once logged in. If this happens to you after refresh the folder will be full. (no idea what causes this but once it shows the files it won't happen again)

 

** EDIT **

Also console in this game sux for using pb commands. As pb can't return reply text to the server console you can't trust that it applied the changes you asked.

 

change these in your file too you will find the very help full. ;)

 

pb_sv_HttpShowGuid 1 //[0=No, 1=Yes (default=0)] <---- player pb guid displayed in web tool

pb_sv_AutoUpdBan 1 //[0=No, 1=Yes (default=0)] <---- If not used any pb bans will not be written to the ban file.

Edited by FuZZie
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.