Jump to content

Banimod Error


Recommended Posts

All mods work fine, apart from Banimod.

 

Log data:

handle 1: rtcwconsole.log

----------------------

12840 files in pk3 files

Sys_LoadDll(/home/kidd62071_1/rtcw/banimod/qagame.mp.i386.so)... ok

Sys_LoadDll(qagame) found **vmMain** at 0xe4029fa0

Sys_LoadDll(qagame) succeeded!

**************************************

* This mod must be run on RTCW 1.41! *

**************************************

------- Game Initialization -------

gamename: banimod

gamedate: Jul 19 2003

========================================

== BANIMOD MEDIAPACK 2003-07-19 FOUND ==

========================================

============================

== BANIMOD MINEPACK FOUND ==

============================

------------------------------------------------------------

InitGame: \g_banimodVersion\1.1.99\mod_url\http://bani.anime.net/banimod/\gamename\banimod\mapname\mp_assault\protocol\60\g_gameskill\3\g_gametype\7\version\Wolf 1.41b-MP linux-i386 May 8 2006\URL\www.escapedturkey.com\g_maxGameClients\24\g_antilag\g_voteFlags\255\g_maxlives\g_friendlyFire\1\sv_floodProtect\1\sv_maxPing\500\sv_minPing\sv_maxRate\25000\sv_hostname\^1ATEAM\timelimit\10\sv_privateClients\4\sv_allowAnonymous\g_minGameClients\g_axismaxlives\g_alliedmaxlives\g_redlimbotime\10000\g_bluelimbotime\10000\g_soldierChargeTime\20000\g_LTChargeTime\40000\g_engineerChargeTime\30000\g_medicChargeTime\45000\g_enableBreath\g_gametype2\1\g_instagib\sv_punkbuster\1\sv_maxclients\24

Gametype changed, clearing session data.

Loading script maps/mp_assault_cp.script

0 teams with 0 entities

22 items registered

-----------------------------------

-----------------------------------

exec <filename> : execute a script file

Hitch warning: 1135 msec frame time

----- Server Shutdown -----

Resolving wolfmaster.idsoftware.com

wolfmaster.idsoftware.com resolved to 192.246.40.70:27950

Sending heartbeat to wolfmaster.idsoftware.com

Resolving rtcwfiles.com

rtcwfiles.com resolved to 38.118.213.21:27950

Sending heartbeat to rtcwfiles.com

Resolving orangesmoothie.com

orangesmoothie.com resolved to 204.13.97.154:27950

Sending heartbeat to orangesmoothie.com

==== ShutdownGame ====

ShutdownGame:

------------------------------------------------------------

---------------------------

^3PunkBuster Server: Running PB Scheduled Task (slot #1) say Recommended PB Configs - 14/10/2006"

Server is not running.

Hitch warning: 2111 msec frame time

^3PunkBuster Server: Game Version [Wolf 1.41b-MP linux-i386 May 8 2006]

^3PunkBuster Server: Running PB Scheduled Task (slot #2) say "www.punksbusted.com"

Server is not running.

Hitch warning: 630 msec frame time

Hitch warning: 575 msec frame time

I'm guessing the "server must be run in 1.41" bit is the issue. However, the server is running:

 

version = Wolf 1.41b-MP linux-i386 May 8 2006

Any ideas?

 

Thanks,

BlackWolf

 

//EDIT

 

Banimod version = 1.1.99

Link to post
Share on other sites

Bani never updated his mod for 1.41b. (something I always found hilarious is how shrub worked fine with 1.41b after all the railing the bani sycophants did about how great bani's work is) Anyway, a player named =FF=Im2good4you had a solution - a plug-in for the Quake 3 Multimod he called 'versionh4x' - it lies to the mod re which version the game is running.

 

Quake 3 Multimod

http://www.q3mm.org/

Version h4x for Rtcw 1.41b/banimod

http://qmm.planetquake.gamespy.com/forums/...c.php?p=218#218

 

I've never used it myself, but I tried a modified version for lying to ET about the game version (to stop the stupid NQ message) and while it worked, I got corrupted memory image error kicks from PB. That said, supposedly the RtCW plug-in didn't have this problem (at least when it was released).

 

edit -> fyi installing q3mm will also protect you against the old q3msgboom exploit. ;)

Edited by Chris64
Link to post
Share on other sites

Bani never updated his mod for 1.41b. (something I always found hilarious is how shrub worked fine with 1.41b after all the railing the bani sycophants did about how great bani's work is) Anyway, a player named =FF=Im2good4you had a solution - a plug-in for the Quake 3 Multimod he called 'versionh4x' - it lies to the mod re which version the game is running.

 

Quake 3 Multimod

http://www.q3mm.org/

Version h4x for Rtcw 1.41b/banimod

http://qmm.planetquake.gamespy.com/forums/...c.php?p=218#218

 

I've never used it myself, but I tried a modified version for lying to ET about the game version (to stop the stupid NQ message) and while it worked, I got corrupted memory image error kicks from PB. That said, supposedly the RtCW plug-in didn't have this problem (at least when it was released).

 

edit -> fyi installing q3mm will also protect you against the old q3msgboom exploit. ;)

Thanks for your help.

 

I've installed Q3MM, and I've downloaded the version spoofer plugin.

 

Just a quick question; where does the versionh4x_qmm.so go?

 

Thanks,

BlackWolf.

 

//EDIT

Noticed it's location is specified in the qmm.ini file

 

Going to test this later. Thanks :)

Edited by =BLACKWOLF=
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.