Jump to content

Corrupted File Memory


Recommended Posts

I get this error when playing for a few minutes on any Call of Duty 2 server:


Server disconnected - Satangel PunkBuster kicked player 'Satangel' (for 0 minutes) ... RESTRICTION: Corrupted File/Memory [81179]a


How can I fix it?

I bought the game from a real store, no D2D or Steam.

Link to comment
Share on other sites

Frequently Asked Questions about PunkBuster for Call of Duty 2

Frequently Asked Questions about PunkBuster Services


Most likely your Client side PB software is not working properly, try to download pbsetup from here, run it, if the problem is still present, do this:

copy the pb folder you have and rename it to pb_old or similar, then make a new folder named pb and move the pbsetup tool in there and run it.

That should and hopefully solve your problem.

Link to comment
Share on other sites

This happens to me once in a while, if I haven't rebooted my pc in a few days. Windows-issue as a possible relation to it, as memory tends to "fill up" over time in Windows operating systems.


Next time it happens, exit the game, hit ctrl+alt+del once, and check where your system resources are at. If your memory is over 50-60% used, likely a reboot will solve it. May depend on operating system, as well. I run Vista 64x Ultimate, SP1, all drivers etc updated, and only run into this after 4-5 days without a reboot.

Link to comment
Share on other sites

I've tried the 2 solutions from above, and they did not help.


And I have Vista 64 Business, and my memory usage was around 30%.

And I always reboot my PC, Ive never left it on for 24 hours or longer.

Link to comment
Share on other sites

tried updating your video card?


I mean only evenbalance knows whats causing this...


How could it be caused by that? The game has been working for 6 months perfectly without updating my Drivers......

I'm gonna reinstall the game, hopefully that helps :)

Link to comment
Share on other sites

Okay, I've reinstalled the game, and now it works :)

I just deinstalld the game, deleted all my profiles and mods and then I installed the game again.

After the game was installed, I installed the 1.3 patch and it worked :)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.