Jump to content

Usersettings kicks


Recommended Posts

Hi. When entering some servers i got punkbuster kicks for "usersettings...len=272" (something like that). I got that kicks even after reinstalling bf2142 complete game and clan mod. When i try to check usersettings folder integrity (by comparing my folder to the same of a clan teammate) i even cant find that folder (when i do that i enter a server, close the game and check). I have tried to copy&paste usersettings folder in its place (from a friend again) and was useless. I have the bf2142 "deluxe edition" and i run vista 32 bits. Any idea? Does anyone has the same problem?

Link to comment
Share on other sites

Usersettings.con is a stock file (not folder) that is installed with BF2142, you can find it in Battlefield 2142/mods/bf2142 for normal BF2142 and mods/clanmod for clanmod IIRC.


Some people 'tweak' their usersettings.con file to improve hit registration, although it's never been proven that this actually works.


Because some server admins consider this an unfair advantage, they run MD5-checks for stock files, including usersettings.con


The problem with this is that it's very unreliable, as there are many more factors that can cause the usersettings.con file to be altered; it's possible that the file is different on the deluxe version of the game.


Basically, if your version of usersettings.con differs from what the server running these checks considers 'normal', you will get kicked.


As this only happens on a handful of servers that run these extra checks, all I can recommend is contacting the server admins and talking to them about it; updates often get released for this check to reduce the chances of an innocent player being kicked.


This is exactly why PBB does not run MD5-checks on these stock files ;)

Link to comment
Share on other sites

Thanks for your answer. I think i have fixed it:


When i tried to execute bf2142 clan mod as administrator i got an error message (="cant find bf2142.exe"). I said "oh somethings wrong over here". I installed in this order: bf2142+patch 1.50 full+clan mod 3.0+clan mod 3.02. Then a teammate told me he was able to execute clan mod as administrator and told he installed clan mod 3.02 FULL (not 3.0+3.02). So i desinstalled clan mod and installed 3.02 Full. Now, when i look at clanmod shortcut properties i realize the destine has changed (before ended with clanmod.bat and now with clanmod.exe) and i am able to execute as administrator. Besides, now i have a folder call "Launcher" that i hadnt before

So the fact is i still got to check if i have fixed the kicks, but now i have my usersetings file (i repeat, before, i coulnd find usersettings file in its place , C:\Program Files\Electronic Arts\Battlefield 2142 Deluxe Edition\mods\clanmod\settings): simply, that file no existed in clanmod, only at bf2142).

Edited by DeckardSp
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use.